Good Morning,

With the introduction of the new multi-core systems, I have taken the time
to look at our universal image to see if there is a way to streamline it a
bit better and make it more modular. The process is now utilizing staged
installs in Winbom.ini then a sysprep re-wrap for final items. I have a
base image 3 addon images (apps, drivers and sysprep) and everything seems
to be working just fine as long as I use the ACPI generic HAL.

My test build machine is a R40 but I have access to other machines (R60,
T60p and A50 desktops). On the R40, the only HAL that will load during
install of XP is the ACPI hal. I tried forcing down the Uniprocessor or
even the Multiprocessor ACPI hal, but it hangs before the first file copy
in the installation. The real issue is that my dual core machines are
still only coming up as ACPI machines plus I have to set compatibility mode
in the bios on the SATA (from ACHI) to have the machine even get past post
and start loading the kernel. On my base image, I did integrate the SATA
drivers into sysprep and once the machine is booted, it shows the SATA
controller just fine. Not sure the issues or problems associated with
running as compatibility mode rather than ACHI, but I am sure there is
probably a performance hit. In the very least, all my users will have to
change that BIOS setting prior to imaging which is another step I would
prefer to avoid. Since the machine gives a BSOD 7B error right after boot
with ACHI selected, I have to assume it is related to the HAL issues since
the kernel hasnt even been processed at that point. Once compatibility
mode is selected, the machine processes and runs fine.

Anyway, since it all seems to boil down the the HAL, I am attempting to do
a dynamic switching of the HAL as an addon image during the imaging
process. I tried following the coolsolution found at

I created an addon image with halmacpi (renamed to hal.dll), ntkrpamp.exe
(renamed to ntkrnlpa.exe) and ntkrnlmp.exe( renamed to ntoskrnl.exe).
These files get dumped down to the windows\system32 directory. Remember,
the base image is the standard Advanced Configuration and Power Interface
(ACPI) PC kernel.

From everything read, the machine should be happy. After post, however,
the machine pauses with just a black screen and reboots. This is with both
compatibility mode and ACHI selected in the BIOS on the SATA controller.

Kinda pulling my hair out figuring this one out. Any ideas?

Once I get this whole thing working, I will be happy to post my process for
others to follow. If its worth knowing. :)