This one's a headscratcher. Sometime (we're not entirely sure, we're
trying to nail it down to a date) around December, whenever we reimage
a workstation either via multicast or by pulling the image file down
manually, an additional partition is created on the workstation. The
original image has two partitions; one is the Dell Utility partition,
and the other is the system partition. Typically, after we reimage the
PC we have to tell the system that the partition type is Dell Utility
so it hides it. We use this command:

echo -e 't/n1/nde/nw/n' | fdisk /dev/sda

Alternately we use /dev/hda if it's an IDE drive instead of a SATA

In the past this has worked, and no additional partitions were created.
However, in the last month or so, it seems that a SECOND Dell Utility
partition is also created. I've looked in the image file and there's
only two partitions. I've tried removing the Dell Utility partition
from the Image file, but then the system won't boot after it's reimaged
(because the boot.ini is looking for the System on the third partition
for some reason).

We've created a new image from a clean PC that had only two partitions
on it, and when we reimaged another PC using that image, it has three

Has anyone seen this behavior? I upgraded the system to 7.1 but that
was back in October and we've done images since then that were fine.
The image in question has not been altered since August of last year
and has been deployed successfully.

Thanks in advance.