Since this is all very new to me, I'll try to detail what I have done to
try to get an RTL8169 Gigabyte Ethernet card to work on our new computers
via Zenworks.

As per TID# 3421576, I tried to get the Linux imaging kernal to recognize
a new device ID. I wasn't totally sure how to do that since the
instructions in the TID were somewhat hard to follow. I used the CD to
load the imaging program. I select manual and it goes through setting up
everything. After a couple of minutes, I am asked the IP of the imaging
server. After I enter that, I then get the "#" prompt. When I do an
ifconfig, it comes up as the NIC not existing giving me a loopback IP of When I do the "hwinfo --netcard" command, I get all the
information regarding the NIC that is in the computer. Problem is, that
NIC won't load. I tried to follow the instructions on the TID where once
gets the Vendor and Device ID#'s (in hex) from the hwinfo --netcard
command. After I did that, I typed in newid="Vendor ID# Device ID#, tg3".
After I hit return, it just went to the "#" prompt again without any
confirmation of whether the above was accepted or rejected. I then typed
IFCONFIG and still got the loopback IP plus it showed that the card wasn't
activated within the imaging program itself.

When I posted this as a result of me having problems on the forum, I was
referred to TID# 3931695. This TID had me get the driver e1000.ko and put
it on my USB drive. I downloaded the December 2006 version of said driver
from Novell. I followed all instructions in the TID in regard to mounting
the USB drive and doing an "insmod e1000.ko" command at the BASH prompt.
I then got the following error "-1 invalid module format". After doing
some research, this error seems to occur when there is something wrong
with how a module is compiled or if it doesn't support the specific piece
of hardware. It seems, that one needs to compile a Linux kernal 2.6
driver for the Realtek (RTL 8169) Gigabyte Ethernet NIC. When I went to
the Realtek site, there is source code for a NIC driver for Linux kernal
2.6 (which I downloaded the *.tar file).

My main problem is that I don't have a clue as to how to compile a Linux
driver. I've seen some information but none of it is like a step-by-step
of how one goes about doing this. In addition, it appears that drivers
for the RTL 8169 have been around for a few months yet they somehow
haven't made it to the bootcd for the Zenworks imaging. Is there any way
to request that said drivers can be included in the next hotfix of the
Zenworks bootcd?

Any ideas as to which way I should go or how I can compile a Linux driver.

Thanks for all your help,