I'm imaging PCs using a 7SP1HP5 boot cd and a USB attached hard drive.
I'm running into long delays between images. After each RL restore
command, the progress bar goes to 100% and then stays there with the
status message of flushing buffers for two minutes then it moves on to the
next ZMG. The version of the BOOTCD doesn't seem to matter since I've
tried several versions and all do the same thing. Any ideas?

Here's the script!

echo ***Windows XP SP1 Image Starting***

sleep 10
zisedit -r

#Delete all partitions
img pdall

#Create primary NTFS Partition
img pc1 ntfs

#Make primary partition active
img pa1

#Base Image
img rl /mnt/usbhd/images/sp1.zmg a1:p1

#Drivers specific to device

#VMWare Workstation Drivers
if hwinfo --bios | grep -i "VMWare" ; then
img rl /mnt/usbhd/images/drivers/vmware.zmg

#Dell c640 Laptop Drivers
#elif hwinfo --bios | grep -i "c640" ; then
# img rl /mnt/usbhd/images/drivers/c640.zmg

#Dell d420 Laptop Drivers
elif hwinfo --bios | grep -i "d420" ; then
img rl /mnt/usbhd/images/drivers/d420.zmg

#Dell d620 Laptop Drivers
elif hwinfo --bios | grep -i "d620" ; then
img rl /mnt/usbhd/images/drivers/d620.zmg

#Dell gx260 Desktop Drivers
elif hwinfo --bios | grep -i "gx260" ; then
img rl /mnt/usbhd/images/drivers/gx260.zmg

#IBM T30 Laptop Drivers
elif hwinfo --bios | grep -i "ThinkPad T30" ; then
img rl /mnt/usbhd/images/drivers/t30.zmg

elif hwinfo --bios | grep -i "236641u" ; then
img rl /mnt/usbhd/images/drivers/t30.zmg

#IBM T40 Laptop Drivers
elif hwinfo --bios | grep -i "ThinkPad T40" ; then
img rl /mnt/usbhd/images/drivers/t40.zmg

#IBM T42 Laptop Drivers
elif hwinfo --bios | grep -i "ThinkPad T42" ; then
img rl /mnt/usbhd/images/drivers/t42.zmg

#IBM T43p Laptop Drivers
elif hwinfo --bios | grep -i "ThinkPad T43p" ; then
img rl /mnt/usbhd/images/drivers/t43p.zmg

#IBM T43 Laptop Drivers
elif hwinfo --bios | grep -i "ThinkPad T43" ; then
img rl /mnt/usbhd/images/drivers/t43.zmg

#IBM T60 Laptop Drivers
elif hwinfo --bios | grep -i "ThinkPad T60" ; then
img rl /mnt/usbhd/images/drivers/t60.zmg

#HP nc6400 Laptop Drivers
elif hwinfo --bios | grep -i "HP Compaq nc6400" ; then
img rl /mnt/usbhd/images/drivers/nc6400.zmg

#HP nc2400 Laptop Drivers
elif hwinfo --bios | grep -i 68YOP ; then
img rl /mnt/usbhd/images/drivers/nc2400.zmg

#HP nc6000 Laptop Drivers
elif hwinfo --bios | grep -i 68BDD ; then
img rl /mnt/usbhd/images/drivers/nc6000.zmg

#HP n610c Laptop Drivers
elif hwinfo --bios | grep -i 68P4F ; then
img rl /mnt/usbhd/images/drivers/n610c.zmg

#HP n600c Laptop Drivers
elif hwinfo --bios | grep -i 686DF ; then
img rl /mnt/usbhd/images/drivers/n600c.zmg

#HP dc7100 Desktop Drivers
elif hwinfo --bios | grep -i 786C1 ; then
img rl /mnt/usbhd/images/drivers/dc7100.zmg

#HP dc5000 Desktop Drivers
elif hwinfo --bios | grep -i 786B0 ; then
img rl /mnt/usbhd/images/drivers/dc5000.zmg

#HP dc5100 Desktop Drivers
elif hwinfo --bios | grep -i 786C2 ; then
img rl /mnt/usbhd/images/drivers/dc5100.zmg

#HP dc5700 Desktop Drivers
elif hwinfo --bios | grep -i 786E2 ; then
img rl /mnt/usbhd/images/drivers/dc5700.zmg

#HP d5000 Desktop Drivers
elif hwinfo --bios | grep -i "d5000" ; then
img rl /mnt/usbhd/images/drivers/d5000-sff.zmg

#HP d530 Desktop Drivers
elif hwinfo --bios | grep -i 786B2 ; then
img rl /mnt/usbhd/images/drivers/d530-sff.zmg

#HP d510 Desktop Drivers
elif hwinfo --bios | grep -i 686O2 ; then
img rl /mnt/usbhd/images/drivers/d510-sff.zmg

#HP w4000 Workstation Drivers
elif hwinfo --bios | grep -i 686Y2 ; then
img rl /mnt/usbhd/images/drivers/w4000.zmg

#HP xw6000 Workstation Drivers
elif hwinfo --bios | grep -i 686O4 ; then
img rl /mnt/usbhd/images/drivers/xw6000.zmg

#HP w6000 Workstation Drivers
elif hwinfo --bios | grep -i 686P8 ; then
img rl /mnt/usbhd/images/drivers/w6000.zmg

else
echo ***NO Drivers Found***
exit
fi

#Addon Packages
img rl /mnt/usbhd/images/addon/windowsupdate.zmg
img rl /mnt/usbhd/images/addon/adobe80.zmg
img rl /mnt/usbhd/images/addon/msoffice2003rev4.zmg
img rl /mnt/usbhd/images/addon/vviewerrev2.zmg
img rl /mnt/usbhd/Images/Addon/cmdlines.zmg


eject




Keith Runge
krunge@websterbank.com