We have to image a couple of HP dc5750 and still have the problem to
get the PCs to read the settings.txt with SATA CD-ROM. Booting from CD
in manual mode the kernel is loading ...
Here´s an extract of the logging ([Alt]+[F3]):

"Hardware probing finished.
there seems to be no floppy disk.
got info from cmdline
mount: /dev/sr0: No such file or directory
Ok, that seems to have worked. :-)
Ok, that seems to have worked. :-)
Looking for ZENworks CD...
disk: trying to mount /dev/sr0
Ok, that didn´t work; see if we can activate another storage device...
No further storage devices found; giving up.
Automatic setup not possible.
udevd-event[xxxx]: create_node: symlink(../../sr0, /dev/disk/by-path/)
failed: File exists"

If we go back with [Alt]+[F1] the error message occured "Make sure that
CD number 1 is in your drive"
We tried to load the kernel in manual mode with "netsetup=-dhcp,all".
We had to type in the IPs manually. After the kernel is loaded we are
able to mount the CD-ROM but this is to late to get the settings from
the settings.txt.

Does anybody know a solution?

HP Compaq dc5750

Bios version 2.25
Settings in the Bios:
Storage Options >>> Sata Emulation = Native Mode IDE
SATA 0 and 2 = Enable
SATA 1 and 3 = Enable

ZDM7 SP1 HP6 Image Resource Files