Hi,

Seems I can't do anything to get around the above error on any inventory
server I've tried to setup.

Environment: NW65 SP5 (all servers), ZFD7. New tree, new servers.

Status report shows (the first error after services start):
2302: Unable to stop Scan Collector Service. The error is
"java.lang.NullPointerException"

Seems it should be trying to start, not stop it ;-)

I turned up debug on the servers and they show:
[6/14/06 15:55:14.029] ZENInv - Scan Collector: Init failed.
java.lang.NullPointerException
at java.util.Hashtable.put(Hashtable.java:393)
at java.util.Properties.setProperty(Properties.java:1 02)
at java.lang.System.setProperty(System.java:656)
at
com.novell.application.zenworks.services.utils.XML Worker.<init>(XMLWorker.java:88)
at
com.novell.application.zenworks.services.utils.XML Worker.<init>(XMLWorker.java:71)
at
com.novell.zenworks.common.inventory.ifs.server.Xm lRpcFileServiceTie.<init>(XmlRpcFileServiceTie.jav a:63)
at
com.novell.zenworks.common.inventory.ifs.server.Fi leServiceController.getServiceController(FileServi ceController.java:125)
at
com.novell.zenworks.common.inventory.ifs.server.Fi leServiceController.initialize(FileServiceControll er.java:65)
at
com.novell.zenworks.common.inventory.scancollector .ScanCollectorService.start(ScanCollectorService.j ava:68)
at
com.novell.zenworks.common.inventory.scancollector .ScanCollector.start(ScanCollector.java:19)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at
com.novell.utility.servicemanager.LoaderThreadGrou p._run(LoaderThreadGroup.java:359)
at
com.novell.utility.servicemanager.LoaderThreadGrou p.run(LoaderThreadGroup.java:395)
at java.lang.Thread.run(Thread.java:534)

I found a TID for an older version of zen that said to create the security
directory and copy the zws.properties from a working server... not an option
since none of the servers (two of them) are working correctly.

I also see lines like the following for scancollector and senderreceiver:
Service Manager: start(ServiceDataAccessor, String[]) not found in
'com.novell.zenworks.desktop.inventory.senderrecei ver.control.SenderServiceInit'

[6/14/06 15:55:13.968] Service Manager: start(ServiceDataAccessor, String[])
not found in
'com.novell.zenworks.common.inventory.scancollecto r.ScanCollector'

Any help would be appreciated.