The zenworks server on our network is running ZENworks 7 now. Most of
the previous machines we had on the network are working just fine
pulling in Windows Group Policies through novell login. Some of the
machines are still running the management agent version 4, and some
were updated to version 7 without problem.

The issue: a number of new computers need to be installed. They are
Dell's with Windows XP SP2. They were started off fresh with Zenworks
for Desktops 7 and then a ghost image was created with zen 7.
Unfortunately, they weren't tested for a variety of policies (we have
multiple labs, each with a different policy depending on the novell
login, the policies are meant to lock down the desktops and prevent
users in labs from messing up machines).

It would seem that the machines do not pick up group policies,
application window and other parts of it show up, but the desktop icons
still show up and other restrictions are not present as they should be.
The original machine was imaged with Symantec Ghost 7.5 and since then
20 clones, renamed afterwords were ghosted down.

Here is what was tried so far:

Reinstall Zen 7.0 From work station - no effect
create different local windows logins - no effect
install 4.0 - worked, but upgrading to 7.0 broke it again

Please let me know if you have any ideas on how to resolve this issue.
Thanks so much.