Okay, let's say I have SOME workstations with HP1 agents, and the rest
are either 7.0 SP1 or 6.5. SP1b

Can I just use the "hp3a" agent for everyone?

Or is hp3a ONLY for "hp1" agents and nobody else?