We've got a Windows 2003 server running eDirectory 8.8sp1 with no post
patches. It is running ZEN 7 SP1 and Middle Tier. The server hosts a
replica of the eDir partition that it serves.

Ever since the server was built, we've run into problems where after a
varying amount of time and activity, authentication fails. Usually 15
minutes. Users can't log in, and any PC that is connected to this Middle
Tier can not be remote controlled until they are rebooted. The PC's have
been able to be redirected to a Middle Tier server I configured at another
location that works consistently.

If I restart IIS on the server, authentication works FINE again for some
time. I have found that if I restart eDirectory, I get the same result;
login works again.

Novell has mentioned that we may be experiencing "heap corruption" similar
to what is mentioned in TID 3404862.

Since then, we have re-installed the OS on the server, a HP DL360 G5, and
only the bare minimum drivers from the HP PSP.

The problem came back with NO outside software installed on the server. We
ran memory diagnostics on the server, and everything came up clean...

I have noticed that when the server was built and rebuilt (with 4096mb
RAM), it did NOT have the /PAE switch in the boot.ini file when ZENworks /
eDirectory was installed. I noticed that it was reporting 3.25GB of RAM,
so I added the /PAE switch and now it reports the correct amount.

We tried base ZEN7sp1, HP3, and now HP4, with no luck.

Does anybody out there have any ideas?

I'd rebuild the server again, but I'm concerned that it will have the same

Any help would be great. We're getting close to a deadline, and I haven't
been able to sort things out with our support call to Novell...