I am currently at ZFD 7.0 and need to apply HP5 in order to image some
new machines.

Looking at the downloads, there is the standard SP1, and more recently
there is SP1 R2 as well as the hotpatch 5 that I need to resolve this
issue. Am I assuming correctly that I want to download and install the
SP1 R2 and then install HP 5? I'm curious...does SP1 R2 include any
updates from the previous or current hotpatches?

We are also using ENGL on top of ZEN for imaging, so I'll need to be
sure the latest ZIM files support the R2 release of the service pack.
If anyone out there can confirm that this combination works - it'd be
much appreciated as well!