The past few days I have been trying to prepare the zenagent 7SP1R2 for
roll out via a zen msi application object, like I had done before
effortlessly with the version 6.5SP2.

I have upgraded our zenserver successfully to 7SP1R2, am using C1 version
1.3.6e (also tried with 1.3.6f)with the 7SP1R2 zen plugins, we are on
nwclient 4.91 SP3, zenagent 65SP2, and all workstations are on XPSP2,
users have full administrator rights to their machines.

The zenagent object force runs in 'silent' mode, BUT at the end of the
installation I get a 'ZENworks application engine has encountered a
problem and needs to close....'

the data report mentions in the error signature 'appname: nalagent.exe
appver: modname: nalagent.exe modver: offset: 00041268'
and more in detail the exception information mentions 'code: 0x000001e
flags: 0x00000000 record: 0x0000000000000000 address: 0x0000000000441268'

clicking through this and after a reboot it seems that it did install

the weird thing is that when I just doubleclick the same zfdagent.msi
(instead of running it via the nal)...I have no issue whatsoever, it
installs without any error. which leads me to think the issue is not MS,
but somewhere between this new version and the way it is handled by the
nal....?I do not have this issue when i run ver 6.5SP2 via the nal on the
same machines...

I have about 200 pc's to upgrade and do not wish to receive 200
usercomplaints about the NALAGENT.exe errormessage

Any help or explanation is more than welcome