NetWare 6.5 SP6
ZfD 7.0.1 SP1 Hotpatch 2

The routine for removal of duplicate workstations from Sybase Inventory Database
cannot connect to the database (dupremove.ncf).

The creation of the duplicate wks list works fine via the server command:
startser NDSLookupForDB

This creates the file:
SYS\ZENworks\Inv\Server\Wminv\Properties\DeleteWSL ist.txt

Then I rename this file to:
SYS\ZENworks\Inv\Server\Wminv\Properties\Inventory RemovalList.txt

Then I run the DUPREMOVE.NCF, but no removal happens,
and the "Zenworks Inventory Dupremove Utility" screen shows:
Trying to (re)connect to the database -> mw_dba
jdbc:sybase:Tds: ONNECT_VERSION=4
*java.sql.SQLException: JZ006: Caught IOException: Connection refused
at com.sybase.jdbc.ErrorMessage.raiseError(ErrorMessa
at com.sybase.tds.Tds.login(
at com.sybase.jdbc.SybConnection.tryLogin(SybConnecti
at com.sybase.jdbc.SybConnection.regularConnect(SybCo
at com.sybase.jdbc.SybConnection.<init>(SybConnection .java)
at com.sybase.jdbc.SybDriver.connect(
at java.sql.DriverManager.getConnection(DriverManager .java:512)
at java.sql.DriverManager.getConnection(DriverManager .java:140)
at com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.createC onnection(
at com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.<init>(
at com.novell.zenworks.desktop.inventory.storer.Datab aseOperator.main(Da
Could not connect to database.
This process does not end, and I have to kill its java process manually.

Might the syntax in the DUPREMOVE.NCF be wrong?
According to the ZEN7 documentation, I've enclosed each parameter within double quotes.
(I've also tried without the quotes, but no improvement)
The effective lines in the DUPREMOVE.NCF are:
java -Djava.compiler= com.novell.zenworks.desktop.inventory.storer.Datab aseOperator "-host=" "-remwsdup=*" "-remwspattern=CN=%" "-dbtype=0"
java -ns -sn"ZENworks Inventory Dupremove utility" -neh -mx128m -classpath $tmppath;"$classpath" -Djava.compiler= com.novell.zenworks.desktop.inventory.storer.Datab aseOperator %1 %2 %3 %4 %5 %6

All other Inventory services works fine, also removing redundant workstations
utilizing the StartSer RemoveInventory command, using the same InventoryRemovalList.txt file.

How do I get the dupremove services to connect to the Inventory Sybase?

- Erik