I've upgraded from Zfd 6.5 to 7 on OES SP1 and am now in the process of
upgrading the clients. I'm doing this via an app object and all goes
well and the user reboots. The problem is the client doesn't appear to
be registering with it's existing workstation object. When I try to
remote control/view the box from the workstation object, I receive this

1487: You are attempting to launch the operation from an obsolete or
invalid workstation object. Verify that the workstation object is valid.

Also, If the workstation has any apps associated to it, they are not
seen in ZEN on the workstation.

I have to zwsreg -unreg and reboot then everything is fine.

Any ideas on how to prevent this from happening during the upgrade?