Hi,

I have a new install of NW6.5 SP6 and ZFD 7 SP1. I am unable to get the ZEN
Workstation Policy to force the printer install. The workstations are
imported correctly as Application associated to the workstation object only
are available on that machine. The machine also installs the iPrint Client
automatically as configured in the Workstation Policy. I have tried a
number of different computers models and printers all with the same result.
I followed TID # 3112868 and setup error logging on the workstation. The
C:\Program Files\Novell\ZENworks\DebugLogs\WmiPrint.log showed the
workstation checking for the iPrint client and attempting to install the
printer but returning an error:

WS - InstalliPrintPrinter - g_pIPrintAddPrinter - ERROR

I have not found any mention of this error anywhere. Following is the
complete log file.


-----------------------------------------------------------
-- DEBUG LOG FILE -- C:\Program
Files\Novell\ZENworks\DebugLogs\WmiPrint.log
-----------------------------------------------------------
09/05/2007 12:33:25:177 WS - Called: WMHelperInitialization()
09/05/2007 12:33:25:177 WS - End: WMHelperInitialization()
09/05/2007 12:33:25:177 WS - Called: WMHelperSystemEntryEx()
09/05/2007 12:33:25:187 WS - WMHelperSystemEntryEx-Running as System
09/05/2007 12:33:25:187 WS - Called: WmiPrintCommonEntry()
09/05/2007 12:33:25:187 WS - zCX = 0x620a88
09/05/2007 12:33:25:187 WS - DN: 00:03:FF:8B:CF:0F.OUNAME.ONAME
09/05/2007 12:33:25:187 WS - treename: TREENAME
09/05/2007 12:33:25:187 WS -
Will apply WINNT Workstation Novell iPrint Policies...
09/05/2007 12:33:25:197 WS - Read the client version number from the Policy
09/05/2007 12:33:25:227 WS - SUCCESS Reading the client version number from
the Directory
09/05/2007 12:33:25:227 WS - iPrintPolicySettings->iPrintClientVersion = 1
09/05/2007 12:33:25:227 WS - Read the iPrint Install flags from the Policy
09/05/2007 12:33:25:297 WS - iPrintPolicySettings->iPrintClientFlags = 0x1
09/05/2007 12:33:25:347 WS - iPrintPolicySettings->iPrintClientLanguage = 2
09/05/2007 12:33:25:447 WS - iPrintPolicySettings->iPrintClientPath =
\\SERVERNAME\SYS\LOGIN\ipp\nipp.exe
09/05/2007 12:33:25:447 WS - Read the Internet printing Address from the
Policy
09/05/2007 12:33:25:477 WS - ERROR reading iPrintInternetAddr
09/05/2007 12:33:25:517 WS - PRINTER FOUND = PRINTERNAME.OUNAME.ONAME
09/05/2007 12:33:25:517 WS - PRINTER INDEX = 0
09/05/2007 12:33:25:517 WS - Reading Attribute - NDPS Printer XRI
09/05/2007 12:33:25:567 WS - NW-GetPrinterURL - curURLValue->value =
uri=ipp://111.111.0.1/ipp/PRINTERNAME
09/05/2007 12:33:25:567 WS - NW-GetPrinterURL - printerURL =
ipp://111.111.0.1/ipp/PRINTERNAME
09/05/2007 12:33:25:567 WS - AddStringToList -- Adding --
ipp://111.111.0.1/ipp/PRINTERNAME
09/05/2007 12:33:25:627 WS - iPrintPolicySettings->iPrintPrinterFlags =
0x10
09/05/2007 12:33:25:627 WS - Enter GetLocaliPrintSettings()
09/05/2007 12:33:26:098 WS - Checking to see of the iPrint Client needs to
be installed...
09/05/2007 12:33:26:098 WS - Enter IsiPrintClientInstalled()
09/05/2007 12:33:26:098 WS - IsiPrintClientInstalled -- INSTALLED
09/05/2007 12:33:26:098 WS - The iPrint Client is INSTALLED
09/05/2007 12:33:27:170 WS - Enter SetLocaliPrintSettings()
09/05/2007 12:33:27:180 WS - InstalliPrintPrinter -
ipp://111.111.0.1/ipp/PRINTERNAME
09/05/2007 12:33:27:550 WS - InstalliPrintPrinter - g_pIPrintAddPrinter -
ERROR
09/05/2007 12:33:27:550 WS - InstalliPrintPrinter result - -1

-----------------------------------------------------------
-- DEBUG LOG FILE -- C:\Program
Files\Novell\ZENworks\DebugLogs\WmiPrint.log
-----------------------------------------------------------
09/05/2007 12:33:15:140 WS - Called: WMHelperInitialization()
09/05/2007 12:33:15:150 WS - End: WMHelperInitialization()
09/05/2007 12:33:15:150 User - Called: WMHelperInteractiveUserEntry()
09/05/2007 12:33:15:150 User - WMHelperInteractiveUserEntry-Pre-Desktop
Helper
09/05/2007 12:33:15:150 User - Enter CleanUpAfteriPrintInstallShield
09/05/2007 12:33:15:150 User - CleanUpAfteriPrintInstallShield --
NippInstallShieldRunOnce Value NOT Found
09/05/2007 12:33:15:150 User - Enter CleanUpAfteriPrintiCapture
09/05/2007 12:33:15:150 User - CleanUpAfteriPrintiCapture --
NippICaptureRunOnce Value NOT Found


Any help would be great.


Thanks,

Kevin