I'm recieving the 1487 error when trying to remote control a WS after
moving the WS object to a different container.

I've search through many posts with the same problem but nobody seems to
post a solution. Here is what I'm doing...

1. login and the WS is succesfully imported, I can then remote control it
2. Move the WS object to a new container.
3. Reboot the WS, now I get the 1487 error.

At this point I can see that the registry is not updated on the workstion
with it's new location.
HKLM>SOFTWARE>NOVELL>Workstation Manager>Identification>Workstation Object.

4. The workstation then re-imports itself to it's original container
defined in the import policy.
5. Now I'm unable to RC either the moved or the new WS object.
6. If I delete both the moved and new objects, reboot. It will then
re-import and can now be remote controlled again.

I'm suspecting a possible problem with the search policy. I have tried
different variations of the search policy placement and configuration but
none seem to get me any better results (mostly worse). I'm not exactly
sure how the search policy should be configured if it even is the problem.

Any help would be apreciated, thank you.

I'm running Zen7 sp1 w/ hotpatch 6.
I have nwclient 4.91sp3
I have reinstalled the zfdagent.
I have removed nmas.
I tried 4.91sp4 client, same issue.
I have enabled debug logging on the WS and Server, can't seem to find any