I am having problems with some D-Link DFE-538TX's. I am trying to get them
to PXE boot so I can image them using ZenWorks. I have successfully tried
other cards in the machine so I am pretty certain it isn't the machine
causing the issues.

When I use the included RTL8139 driver that comes with the !PXE-On-Disk
program included with ZenWorks it takes about 3 hours to get booted into
linux to do the imagining (only about 5 MB or so download I think). The
imaging goes at the speed it should.

I think it may be a driver issue but I am having problems getting D-Links
538 driver to boot. I get this error:

PreWorx (Pty)Ltd onDisk Loader v1.409
Copyright 1999-2003 PreWorx (pty) Ltd.
Please wait while loader initializes
D-Link DFE-538TX 10/1000 Adapter Driver installation failed
Fast Ethernet Adapter was not found in this system
Hit any Key to continue...
Error: NDIS extry point was NULL/invalid
The boot process continues.

I tried adding my own driver to the program. I downloaded the current driver
from D-Link.

The .dos file is dated Tuesday, June 27, 2000, 7:14:00 PM.

The section I added to the PXEClient.ini file is this:

DeviceName =D-Link DFE-538TX 10/100 Network Adapter
Driver1 =dlk538.dos
LoadOptions1 =1
ImageType1 =9
LofLEntry1 =1
Parameters1 =

Driver2 =dlk538.ini
LoadOptions2 =4
ImageType2 =9
LofLEntry2 =4
Parameters2 =

Driver3 =undi40.bin
Loadoptions3 =1
ImageType3 =1
LofLEntry3 =5
Parameters3 =

Driver4 =pxe.bin
Loadoptions4 =4
ImageType4 =1
LofLEntry4 =7
Parameters4 =

I had to rename the dos file to dlk538.dos since a dlkfet.dos file already

This is what I added to the dlk538.ini file:

DriverName = DLK538$

Any idea what I am doing wrong?