Hello again,

Up to now, most of our imaging has been done in areas we control. We have
therefore not had a problem with enabling portfast on switches so that DHCP
will work the ZENWorks Linux boot.

Now we are offering imaging to a much wider audience, including people in
departments that control their own networking. We cannot guarantee that
these people will not, at some point in the future, plug a hub or switch
into a particular switch port. Consequently we simply CANNOT enable
portfast everywhere. It is not an option.

There appears to be a basic problem with the two methods that are used to
get DHCP addresses in Linux. Both pump and dhcpcd do stupid things when
portfast isn't enabled. The Cisco switch I'm using to do testing on takes
30 seconds to allow traffic on a port when portfast isn't enabled. Pump,
quite stupidly, appear to reset the port when it begins trying to get a DHCP
address. Consequently, even if the Cisco switch had previously enabled that
port, it goes disabled and spends 30 seconds being unusable. During that
time, pump gives up and times out. (Actually it's slightly worse -- a few
seconds into the thirty-second window, it resets the port AGAIN and starts
over.) I have experimented with timeouts and retries for pump (and dhcpcd)
without any success.

All the research I've done into people having problems with this with
mainstream Linux boots have ended up with the same advice -- enable portfast
and all your problems will be over. I can't do this.

Anybody out there who knows more about Linux than I do have any words of