I am testing workstation and server imaging and cannot get PXE to find
work for auto-imaging. I have created an image object in console one,
verified rights to the image file, and set the server policy package to
drop an image on the mac address of the pc I am testing.

Everytime I boot off of PXE it gets an IP and then says "ZENWorks
shutting down..." and then quits. I am able to manually image the
machine if i boot to the maintance menu <ctrl-alt>, however I am trying
to automate and not have the pc-techs run around our enviroment to
every machine.

I have been able to force start the auto-imaging via the maintenance
menu, then it gets to the img menu and screen, but quickly quits and I
get the message "no work to do". Even though I know that there is work
to be done (as setup in the server policy) and have set it up properly.

My guess is that I have missed a simple step somewhere... Any help
would be great, as this is very frustrating!

I looked at the tftp.ini and verified the settings.

here is our setup:
-dhcp server is NOT on the zen server.
-I added option 66 to the dhcp server - tftp - points to the zenserver
(this allows PXE to at least grab an IP and find the zen server)
-I have verified that option 60 - PXEclient is NOT on the global

Here is what the output states from the machine:
Network boot from AMD Am79c970a
copyright (c) 2003 vmware, inc.
copyright (c) 1997-2000 intel corp.

client mac addr: xx:xx:xx:xx:xx guid: xxxxxxx-xxx-xx-xxxx
client ip: Mask:
dhcp ip: proxy ip:
gateway ip:

zenworks boot

boot server ip:
zenworks network management
preworkx (pty) ltd.
local ip:
subnet mask:
transaction server ip:
gateway ip:
ZENworks shutting down...
PXE-M0F: Exiting Intel PXE ROM


Justin Peachey