Windows could not start because the following file is missing or corrupt:

<Windows root>\\system32\hal.dll.

Please re-install a copy of the above file

Dell Inspiron 6400, Dual Core, Windows XP SP2



We recently purchased about 30 of the following systems: DELL Inspiron6400
(see above). After installing the desired programs I created IMAGEA for
this laptop. Creating and restoring IMAGEA was not a problem. Later, I
created IMAGEB which is a little bit different than the other image. A few
more programs and bit more of restrictions. Creating IMAGEB was successful
and had no problems however, restoring IMAGEB onto the same laptops gave me
following problems:

- Restoring IMAGEB (img rp...) onto the laptop begins as normal without any
problems. I see the screen which shows me the progress of the image
restoral but about 5 minutes into restoring the image the program stops and
exits. All I get is the linux prompt (/#). No messages just the prompt.
Then, when I restart the laptop I get the error message shown above
(...missing or corrupt hal.dll...)

- At first I thought there might have been a problem with the image so I
recreated IMAGEB again but I got the same errors when I tried to re-image
the laptop.

- I then decided to restore IMAGEA onto this laptop and that posed no
problems. Restoring IMAGEA was successful.

I am not sure what is so different about IMAGEB that does not work when I
tried to restore it (img rp...). I do not know what could possibly be the

Any solution, recommendation, or advice is greatly appreciated.