Hello all,

For a long time now we have had an imaging system based on ZENWorks
4.x-esque materials. Some months ago we tried to upgrade our back end to
6.5 SP2. We had a problem which led us to roll back. Now that 6.5 SP2 IR1
is available, we thought we would try it to see whether it still had the
same problem as its predecessor. It doesn't, hooray.

However, the architecture has completely changed relative to 4.x. There are
now CMD files (for PXE boot) containing the boot loader parameters and the
default material supplied by Novell are no longer called linux.1, linux.2
etc. but rather boot, root, initrd.

This is all well and good, but I have extensive modifications to the default
Novell materials and I'm not going to reverse engineer the existing supplied
materials and try to make my changes to them when I don't really require
anything new that they provide. In other words, my existing stuff is
working fine; I just want to launch it with the new back end.

So, I edit the CMD files and replace filenames as appropriate to use my
linux.1 etc. Voil, all is well. I tried it on several of my usual test
machines without any trouble at all. But then, when I went to roll it out
in general, I found problems. Some particular hardware types kernel panic.
It is a frustrating panic in that I only get the panic line; I don't get
anything useful saying what the problem was. Nevertheless, it appears to be
the case that either it can't find the ramdisk or is trying to use
completely the wrong thing for root. This is the only line I get:

Kernel panic -- not syncing: VFS: Unable to mount root fs on

Where x and y can be various integers.

I don't know where to begin with this. The problem appears to be a logical

1. These are the same boot materials I have used all along, successfully,
on all hardware types. They have not changed. Why should they now kernel
panic on some and not others?

2. The PXE process is merely delivering the same exact kernel and initrd as
it previously did. It used to work successfully on all hardware types. Why
should the mode of delivery have caused it to break, but only on some

3. I would be inclined to blame incorrect parameters being supplied to the
kernel, but again, why should "incorrect" parameters work on half my

4. I would suspect that the ramdisk or the kernel was corrupt except that
the same exact files work on other machines. The difference between success
and failure is the machine, not the files.

5. I would suspect that the ramdisk was far too small to hold its contents
except, again, it works on half my hardware.

In general, the hardware that works is newer, e.g. Dell GX280. But
working/non-working hardware are similar in terms of memory (at least half a
gigabyte), CPU (2.4 GHz +), and other superficial things. I thought
initially that there was a difference between disk types: sata succeeded,
IDE failed; but we've just had a successful test on an IDE disk.

Does anybody who knows more about Linux than I do have any ideas about
what's going wrong?

Does anybody have any idea what the actual boot loader is in these newer PXE
materials? It appears to be called loadlin.dnx but it can't really be
loadlin because loadlin comes from DOS and there isn't any DOS involved as
there used to be. It might be useful if I could look at a list of boot
loader parameters, but I don't know what the boot loader really is.