Hi all.

I have tried finding articles about this but have only found ones for
higher versions of the kernel than what I have.

To start, I think I know what I have to do to actually update the linux.2
file with the latest e1000 NIC drivers. My problem is, I don't know what
version of linux to use that has the 2.4.32-pre3 kernel. Everywhere I
look, I can get the 2.6.x.x kernel in almost any form, but not the 2.4

Please help, or if there is another way, let me know. I essentially need
to compile the e1000 driver on the 2.4.32-pre kernel and don't know what
linux version to download and use.