Has anyone run into any significant problems with upgrading the servers
to ZfD 6.5 but keeping the ZfD WS Agent at the Interim Release 4, ZfD
4.01 version?

From the issues having to do with Memory leaks, I don't think I want to
update the WS just yet.

Dan