I am installing Zenworks 6.5 for Linux on a RedHat Enterprose ES 3.0 that
was updated before the installion of Zenworks.

The installion fails because rcd will not run. I found this in the
/var/log/messages

Sep 28 09:31:43 dclnpzen1 rcd[18103]: Red Carpet Daemon 2.2.0
Sep 28 09:31:43 dclnpzen1 rcd[18103]: Copyright (C) 2000-2003 Ximian Inc.
Sep 28 09:31:43 dclnpzen1 rcd[18103]: Start time: Tue Sep 28 09:31:43 2004
Sep 28 09:31:43 dclnpzen1 rcd[18103]: Couldn't access the packaging system:
this version of RPM is not yet supported

rpm show this version of rpm (Ver 4.2.3-10)

[root@dclnpzen1]# rpm -qa | grep rpm
rpm-libs-4.2.3-10
rpm-python-4.2.3-10
redhat-rpm-config-8.0.28-2
rpm-build-4.2.3-10
rpm-4.2.3-10
rpmdb-redhat-3-0.20040902
redhat-java-rpm-scripts-1.0.2-2
rpm-devel-4.2.3-10

What do I need to do?