We are thiniking of upgrading from Zen 3.2 to zen desktop 6.5.

Most servers are 5.1 wich means that we cannot upgrade to zen desktop 6.5 ?

Do the 2 version work together, I mean can I run them parallell in my tree,
on even on same server ?

So that I can upgrade clients in my own tempo.