I have a call open with Novell about this, but maybe someone can answer me

Zenworks 6.5 suite is not supported on Netware 5.1 SP7, right?

To get round this, ZfD4.01 could be installed on 5.1SP7, right?

We currently run Zfd3.2SP3 on our servers, and this is coming towards
it's 'end of life'. We are not in a position to upgrade our Netware
servers to the latest version just yet, so we are looking to upgrade to
Zfd4.01, and then upgrade our servers to the lastest version and then
upgrade to Zenworks 6.5 suite. Does this seem ok?