NetWare 6.5 SP3
ZfD 6.5 SP1b

Workstation import not working towards a given import server.
Importing the same wks in another import server works ok,
so the problem is server related.

Wks import fails because the ZfD server does not listen on port 8039.
All Java services for wks import seems ok (java -show).
All the appropriate registry settings, policies and dns config are in

Verbose debug (level 3) for the wksimport service on the server registers
seems as the wks registering request never reaches or is received on the

Verbose debug at the wks states (extracted section) this:
(note the last line...)
08/26/2005 10:01:55 ZENWSREGRegister -- Connecting to server <> port
08/26/2005 10:01:55 ZENWSREGRegister -- hConnect = 33619969
08/26/2005 10:01:55 ZENWSREGRegister -- hRequest = 50397185
08/26/2005 10:01:55 ZENWSREGRegister -- Finished opening request. hRequest
= 3010001.
08/26/2005 10:01:55 ZENWSREGRegister -- About to send the following
08/26/2005 10:01:55 ZENWSREGRegister -- <?xml version="1.0"
<cpu>PENTIUM III</cpu>
<os>WIN2000 (5.0 Service Pack 4)</os>

<user_dn>Testelev99.1999.Elever.Brukere.Grevelokka .BSKOLER.SKOLER</user_dn>

08/26/2005 10:02:16 ZENWSREGRegister -- Last error = 12029
08/26/2005 10:02:16 ZENWSREGRegister -- Error:
08/26/2005 10:02:16 ZENWSREGRegister -- Leaving HTTPUtil::SendMessage,
returning 12029
08/26/2005 10:02:16 ZENWSREGRegister -- Entering HTTPUtil::SendMessage
08/26/2005 10:02:16 ZENWSREGRegister -- Aborting SendMessage. Server
address is empty.

TCPCON states that port 8039 is listening on local IP (which I
believe is false!)
Portscanning the ZfD import server, shows it does NOT listen on port 8039.
Telnet <ipddress> 8039 does not respond either.
Both portscan and telnet works ok on the other functioning import server!

I have reapplied ZfD65 SP1b, I have reinstalled JVM 1.4.2_06, but no

I believe import fails because the import service does not listen on port
All other listening ports shown in TCPCON responds to telnet, and they are
also visible in portscan,
all except 8039!
How can I revive port 8039 on this import server, to ensure wks import to