If you previously had 6.5sp1hotpatch 3 installed, you may run in to problems
when you try and upgrade to the SP2 agent.

for some daft reason hotpatch 3 had version numbers of & for
zenapws.dll & nalntsrv.exe so the agent install will not
replace these files, so make sure you remove the old agent first. or I think

We had to roll out hotpatch3 in a live environment because we had so many
machines affected by the hyperthreading bug and at the time there was no
release date for sp2.

This sounds a lot like the recent Netware 6.5sp4 mixup where all the version
numbers where recently messed up by not being updated in the service pack!!

Hope this helps,

Nathan Lock