NW 6.5 SP5
ZfD 6.5 SP2

I have a server running ZfD imaging and wks import/removal.
This server runs ZfD 6.5 SP2.
Now I also need to install Inventory services from my product CD.
But installing ZfD Inventory services from the product CD
degrades ZfD 6.5 back to v6.5.0.4, while it before Inventory install was
running v6.5.2.0 (SP2 installed).

I therefore need to reinstall SP2, but installation fails, stating that either I'm not
logged in with proper rights (although logged in as admin), or ZfD is not installed
on the server.

I have tried all possible combinations of the registry settings described in TID 10098135,
and I have also tried to install SP1a before SP2, but nothing helps.

Looking at the ZfDDebug.log, the last lines in the log are:

SelectProductsPage: Adding IMAGE_FS1.ADM.HAMAR_KOMMUNE to valid Servers
SelectProductsPage: Number of valid servers = 1
SelectProductsPage: server [0] = HAMAR_TREE IMAGE_FS1.ADM.HAMAR_KOMMUNE 6 IMAGE_FS1
SelectProductsPage: Attempting to authenticate to IMAGE_FS1
SelectProductsPage: Authenticated to IMAGE_FS1
getZenworksVersion: Attempting to get zenworks version from IMAGE_FS1
getTextFile: \\IMAGE_FS1\SYS\System\zenquery.out

But the file zenquery.out does not exist anywhere...

It seems as if the SP2 installer cannot determine whether ZfD is installed in the server at all,
or that the version cannot be read out.

I have revived the tftp imaging services via salvage, but i fear that there ar far more
files that hav been set back to v6.5.0.4 insted of the correct (and actually installed) v6.5.2.0.

What must I do in order to reinstall ZfD 6.5 SP2 again?
And why is there not any updated product CD iso-file including SP2 to download?
Every download are old iso images...

Please help!