All,

Below is a detailed description of a resistration issue using Zenworks
Linux Management 7.

Hardware Configuration:
1- DSL Modem (Westell Model 2200)
1- DI 614+ 2.4 GHz Broadband Wireless Router (includes 4-5 ethernet
ports) with a IP address of 192.168.0.1
1- PC Server running Redhat SUSE Linux Enterprise Server 9 (has a static
IP address of 192.168.0.103). This machine is running the Zenworks 7
Linux Management Software and is able to sucessfully launch the Zenworks
7 Control Panel.
1- Redhat Linux Enterprise Server 3 on a completely different network
with a static IP address (207.44.142.56). This machine is running the
Zenworks Linux Management Agent install using the ./zlm-install -a
command.

Network Configuration:
The broadband DSL modem is connected directly to the WAN ethernet port on
the wireless router
The primary PC server running Redhat SUSE Linux Enterprise Server 9 has a
direct connection to one of the ethernet ports on the wireless broadboard
router with a private static IP address of 192.168.0.103 and has a public
IP of 70.22.107.168.
The DSL modem is has a direct connection to the telephone line.
The Redhat Linux Enterprise Server 3 is on a completely different network
with a IP of 207.44.142.56.
No firewalls are configured on the primary server and the wireless router
Port Forwarders are configured on the broadband wireless router as
follows:
zlm1
192.168.0.103
TCP 80/80
always

zlm2
192.168.0.103
TCP 443/443
always

zlm3
192.168.0.103
TCP 524/524
always


zlm4
192.168.0.103
TCP 1299/1299
always

zlm5
192.168.0.103
TCP 2544/2544
always

zlm6
192.168.0.103
TCP 5506/5506
always

zlm7
192.168.0.103
TCP 10389/10389
always

zlm8
192.168.0.103
TCP 10636/10636
always

Goal:
To successfully register the Redhat Linux Enterprise 3 server (i.e. the
managed device with IP 207.44.142.56) with the primary server
(192.168.0.103 SUSE Redhat Enterprise Server 9 machine) so it can be
viewed and managed from the Zenworks 7 Control panel.

Nature of Problem:
When attempting to register the managed device (207.44.142.56) with the
primary server (192.168.0.103) which resides inside of my Wireless Local
Area Network (WLAN) via the following command, it appears to fail. I'm
unable to view or configure this managed device inside of the Zenworks 7
Linux Management Control Panel. The following are 2 manual approaches
that I take to register the managed device and the results for each.

Register using private IP approach:
/opt/novell/zenworks/bin/rug sa https://192.168.0.103
Results: ERROR: Could not add 'https://192.168.0.103': Download failed:
(https://192.168.0.103/zenworks-registration/service.xml) Error:
ConnectFailure

Register using public IP approach:
/opt/novell/zenworks/bin/rug sa https://70.22.107.168
Results: ERROR: Could not add 'https://70.22.107.168': Download failed:
(https://192.168.0.103/zenworks-registration/service.xml) Error:
ConnectFailure

Any feedback or suggestions on a resolution to this issue would be great.
Our company is very interested in purchasing several e-licenses for this
product to support our clients.

Regards,
Darrick Addison
Sr. Software Engineer/Consultant
ASC Technologies, LLC
Ph: 443.257.9116
Fax: 410.360.5570
E-mail: asctllc@verizon.net
Web: www.asctllc.com