Hi everybody !

I haved install Zenworks Linux Management on SLES 9 SP 2 server. The
installation will work great except some dependecy issues that i have
resolv. Now i tried to add managed device, i have try with an other SLES 9
SP 2 server , but without success :( This is the error :

# rug sa zenworks-server/

ERROR: Could not add 'zenworks-server/': Error in registration: Content is
not 'text/xml' but 'text/html;charset=utf- 8'
Response error message:
--
<html><head><title>Apache Tomcat/5.0.28 - Error
report</title><style><!-- H1
{font- family:Tahoma,Arial,sans- serif;color:white;background-
color:#525D76;font- size:22px;}
H2
{font- family:Tahoma,Arial,sans- serif;color:white;background-
color:#525D76;font- size:16px;}
H3
{font- family:Tahoma,Arial,sans- serif;color:white;background-
color:#525D76;font- size:14px;}
BODY
{font- family:Tahoma,Arial,sans- serif;color:black;background- color:white;}
B
{font- family:Tahoma,Arial,sans- serif;color:white;background- color:#525D76;}
P
{font- family:Tahoma,Arial,sans- serif;background:white;color:black;font-
size:12px;}A
{color : black;}A.name {color : black;}HR {color : #525D76;}-- ></style>
</head><body><h1>HTTP Status 500 - </h1><HR size="1"
noshade="noshade"><p><b>type</b> Exception report</p><p><b>message</b>
<u></u></p><p><b>description</b> <u>The server encountered an internal
error () that prevented it from fulfilling this
request.</u></p><p><b>exception</b> <pre>javax.servlet.ServletException:
An error occurred creating the service store.

com.novell.zenworks.webservice.registration.Regist rationImpl.init(RegistrationImpl.java:51)

org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:118)

org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:535)
org.apache.coyote.tomcat5.CoyoteAdapter.service(Co yoteAdapter.java:160)

org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:799)

org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.processConnection(Http11Protocol.jav a:705)

org.apache.tomcat.util.net.TcpWorkerThread.runIt(P oolTcpEndpoint.java:577)

org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:683)
java.lang.Thread.run(Thread.java:534)
</pre></p><p><b>root cause</b>
<pre>com.novell.zenworks.datamodel.exceptions.Inte rnalDataModelException:
An error occurred creating the service store.

com.novell.zenworks.datamodel.extensions.DirectSer viceStoreImpl.factoryServiceStore(DirectServiceSto reImpl.java:95)

com.novell.zenworks.webservice.registration.Regist rationImpl.init(RegistrationImpl.java:46)

org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:118)

org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:535)
org.apache.coyote.tomcat5.CoyoteAdapter.service(Co yoteAdapter.java:160)

org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:799)

org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.processConnection(Http11Protocol.jav a:705)

org.apache.tomcat.util.net.TcpWorkerThread.runIt(P oolTcpEndpoint.java:577)

org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:683)
java.lang.Thread.run(Thread.java:534)
</pre></p><p><b>note</b> <u>The full stack trace of the root cause is
available in the Apache Tomcat/5.0.28 logs.</u></p><HR size="1"
noshade="noshade"><h3>Apache Tomcat/5.0.28</h3></body></html>


What can i do to resolv these issue ?

thanks

Michael









> >