Hi Guys,

I have a problem, and im not sure if its how ZLM works, or im missing
something.

I use zlmmirror to mirror all SLES10 updates. This automatically
creates a SLES10 catalog and bundle with all of the RPM's inside it.

I assign this catalog to another server and from that server, i see
all the patches and updates. Running rug up shows major dependency
errors (listed below).

Do the servers only update the packages that they have installed? That
would make sense, im just not 100% that is the case?

What should I do about these dependency issues. It looks like its
trying to remove aaa_base. Is this correct?

My other issue is I issue a rug sum command, and this shows only 118
Other updates. Im sure there must be security and recommended updates?
Why do I only have other?

Thanks in advance.

Stefan

---

vcp-bc3-bl12:~ # rug sum
There are 118 updates available at this time.

Catalog | Security | Recommended | Optional | Other | Total
---------------+----------+-------------+----------+-------+------
SLES10-Updates | 0 | 0 | 0 | 118 | 118




Resolving Dependencies...

ERROR: Dependency resolution failed:
Unresolved dependencies:
Updating gstreamer010-plugins-base-0.10.5-11.2.x86_64[System packages]
to gstreamer010-plugins-base-0.10.5-11.6.x86_64[SLES10-Updates]
Updating sax2-ident-1.7-125.18.x86_64[System packages] to sax2-
ident-1.7-125.22.x86_64[SLES10-Updates]
Updating gnome-main-menu-0.6.1-0.6.x86_64[System packages] to gnome-
main-menu-0.6.1-0.15.x86_64[SLES10-Updates]
Updating ksh-93r-12.9.x86_64[System packages] to
ksh-93r-12.14.x86_64[SLES10-Updates]
Updating samba-client-3.0.22-13.16.x86_64[System packages] to samba-
client-3.0.22-13.30.x86_64[SLES10-Updates]
Updating xorg-x11-server-6.9.0-50.14.x86_64[System packages] to xorg-
x11-server-6.9.0-50.32.5.x86_64[SLES10-Updates]
Updating yast2-vm-2.13.58-0.2.x86_64[System packages] to yast2-
vm-2.13.62-4.2.x86_64[SLES10-Updates]
Updating rpm-4.4.2-43.4.x86_64[System packages] to
rpm-4.4.2-43.7.x86_64[SLES10-Updates]
Updating sysstat-6.0.2-16.4.x86_64[System packages] to
sysstat-6.0.2-16.7.x86_64[SLES10-Updates]
Updating yast2-storage-2.13.69-0.2.x86_64[System packages] to yast2-
storage-2.13.70-0.5.x86_64[SLES10-Updates]
Updating diffutils-2.8.7-17.2.x86_64[System packages] to
diffutils-2.8.7-17.5.x86_64[SLES10-Updates]
Updating mkinitrd-1.2-106.14.x86_64[System packages] to
mkinitrd-1.2-106.25.x86_64[SLES10-Updates]
Updating openssh-4.2p1-18.2.x86_64[System packages] to
openssh-4.2p1-18.12.x86_64[SLES10-Updates]
Updating yast2-sound-2.13.11-3.2.x86_64[System packages] to yast2-
sound-2.13.11.1-0.2.x86_64[SLES10-Updates]
Updating evolution-data-server-1.6.0-43.20.x86_64[System packages] to
evolution-data-server-1.6.0-43.28.3.x86_64[SLES10-Updates]
Updating net-snmp-5.3.0.1-25.2.x86_64[System packages] to net-
snmp-5.3.0.1-25.5.x86_64[SLES10-Updates]
Updating gnome-session-2.12.0-106.16.x86_64[System packages] to gnome-
session-2.12.0-106.28.x86_64[SLES10-Updates]
Updating gnome-screensaver-2.14.0-19.6.x86_64[System packages] to
gnome-screensaver-2.14.0-19.12.x86_64[SLES10-Updates]
Updating yast2-cd-creator-2.13.3-1.2.noarch[System packages] to yast2-
cd-creator-2.13.5-6.2.noarch[SLES10-Updates]
Updating yast2-samba-client-2.13.22-0.2.noarch[System packages] to
yast2-samba-client-2.13.24.2-0.2.noarch[SLES10-Updates]
Updating evince-0.4.0-25.2.x86_64[System packages] to
evince-0.4.0-25.5.x86_64[SLES10-Updates]
diffutils-2.8.7-17.2.x86_64[System packages] provides /usr/bin/cmp,
but is scheduled to be uninstalled.
Can't satisfy requirement /usr/bin/cmp for
aaa_base-10-12.8.x86_64[System packages]
net-snmp-5.3.0.1-25.2.x86_64[System packages] replaced by net-
snmp-5.3.0.1-25.5.x86_64[SLES10-Updates]
yast2-sound-2.13.11-3.2.x86_64[System packages] replaced by yast2-
sound-2.13.11.1-0.2.x86_64[SLES10-Updates]
openssh-4.2p1-18.2.x86_64[System packages] replaced by
openssh-4.2p1-18.12.x86_64[SLES10-Updates]
diffutils-2.8.7-17.2.x86_64[System packages] replaced by
diffutils-2.8.7-17.5.x86_64[SLES10-Updates]
yast2-storage-2.13.69-0.2.x86_64[System packages] replaced by yast2-
storage-2.13.70-0.5.x86_64[SLES10-Updates]
xorg-x11-server-6.9.0-50.14.x86_64[System packages] replaced by xorg-
x11-server-6.9.0-50.32.5.x86_64[SLES10-Updates]
samba-client-3.0.22-13.16.x86_64[System packages] replaced by samba-
client-3.0.22-13.30.x86_64[SLES10-Updates]
sax2-ident-1.7-125.18.x86_64[System packages] replaced by sax2-
ident-1.7-125.22.x86_64[SLES10-Updates]
aaa_base-10-12.8.x86_64[System packages] dependend on diffutils
aaa_base-10-12.8.x86_64[System packages] is missing the requirement /
usr/bin/cmp
aaa_base-10-12.8.x86_64[System packages] provides aaa_base == 10-12.8,
but is scheduled to be uninstalled.
There are no installable providers of aaa_base for
plotutils-2.4.1-591.2.x86_64[System packages]
aaa_base-10-12.8.x86_64[System packages] provides aaa_base == 10-12.8,
but is scheduled to be uninstalled.
There are no installable providers of aaa_base for
hal-0.5.6-33.10.x86_64[System packages]
aaa_base-10-12.8.x86_64[System packages] provides /sbin/SuSEconfig,
but is scheduled to be uninstalled.
There are no installable providers of /sbin/SuSEconfig for
permissions-2006.5.19-0.3.x86_64[System packages]
aaa_base-10-12.8.x86_64[System packages] provides /etc/bash.bashrc,
but is scheduled to be uninstalled.
There are no installable providers of /etc/bash.bashrc for
ksh-93r-12.14.x86_64[SLES10-Updates]
aaa_base-10-12.8.x86_64[System packages] provides /sbin/chkconfig, but
is scheduled to be uninstalled.
There are no installable providers of /sbin/chkconfig for net-
snmp-5.3.0.1-25.5.x86_64[SLES10-Updates]
aaa_base-10-12.8.x86_64[System packages] provides /sbin/chkconfig, but
is scheduled to be uninstalled.
There are no installable providers of /sbin/chkconfig for samba-
client-3.0.22-13.30.x86_64[SLES10-Updates]
hal-0.5.6-33.10.x86_64[System packages] dependend on aaa_base
hal-0.5.6-33.10.x86_64[System packages] is missing the requirement /
etc/init.d/boot.localfs
samba-client-3.0.22-13.30.x86_64[SLES10-Updates] dependend on aaa_base
net-snmp-5.3.0.1-25.5.x86_64[SLES10-Updates] dependend on aaa_base
ksh-93r-12.14.x86_64[SLES10-Updates] dependend on aaa_base
permissions-2006.5.19-0.3.x86_64[System packages] dependend on
aaa_base
permissions-2006.5.19-0.3.x86_64[System packages] is missing the
requirement /sbin/SuSEconfig
plotutils-2.4.1-591.2.x86_64[System packages] dependend on aaa_base
plotutils-2.4.1-591.2.x86_64[System packages] is missing the
requirement aaa_base
plotutils-2.4.1-591.2.x86_64[System packages] provides libplot.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libplot.so.2()(64bit) for
gnuplot-4.0.0-20.2.x86_64[System packages]
permissions-2006.5.19-0.3.x86_64[System packages] provides permissions
== 2006.5.19-0.3, but is scheduled to be uninstalled.
There are no installable providers of permissions for
openssh-4.2p1-18.12.x86_64[SLES10-Updates]
permissions-2006.5.19-0.3.x86_64[System packages] provides permissions
== 2006.5.19-0.3, but is scheduled to be uninstalled.
There are no installable providers of permissions for
rpm-4.4.2-43.7.x86_64[SLES10-Updates]
permissions-2006.5.19-0.3.x86_64[System packages] provides permissions
== 2006.5.19-0.3, but is scheduled to be uninstalled.
There are no installable providers of permissions for util-
linux-2.12r-35.6.x86_64[System packages]
permissions-2006.5.19-0.3.x86_64[System packages] provides permissions
== 2006.5.19-0.3, but is scheduled to be uninstalled.
There are no installable providers of permissions for xorg-
x11-6.9.0-50.14.x86_64[System packages]
desktop-file-utils-0.10-22.2.x86_64[System packages] provides desktop-
file-utils == 0.10-22.2, but is scheduled to be uninstalled.
There are no installable providers of desktop-file-utils for gnome-
vfs2-2.12.2-58.10.x86_64[System packages]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
evince-0.4.0-25.5.x86_64[SLES10-Updates]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
gnome-screensaver-2.14.0-19.12.x86_64[SLES10-Updates]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
gnome-session-2.12.0-106.28.x86_64[SLES10-Updates]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
evolution-data-server-1.6.0-43.28.3.x86_64[SLES10-Updates]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
gnome-main-menu-0.6.1-0.15.x86_64[SLES10-Updates]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
sax2-7.1-125.18.x86_64[System packages]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
hwinfo-12.34-0.2.x86_64[System packages]
dbus-1-0.60-33.2.x86_64[System packages] provides libdbus-1.so.2()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libdbus-1.so.2()(64bit) for
libzypp-2.15.4-0.3.x86_64[System packages]
hwinfo-12.34-0.2.x86_64[System packages] dependend on hal
hwinfo-12.34-0.2.x86_64[System packages] is missing the requirement
hal >= 0.5.2
sax2-7.1-125.18.x86_64[System packages] dependend on hal
sax2-7.1-125.18.x86_64[System packages] is missing the requirement hal
gnome-main-menu-0.6.1-0.15.x86_64[SLES10-Updates] dependend on hal
libzypp-2.15.4-0.3.x86_64[System packages] dependend on hal
libzypp-2.15.4-0.3.x86_64[System packages] is missing the requirement
libhal.so.1()(64bit)
gnome-vfs2-2.12.2-58.10.x86_64[System packages] dependend on hal
gnome-vfs2-2.12.2-58.10.x86_64[System packages] is missing the
requirement libhal.so.1()(64bit)
evolution-data-server-1.6.0-43.28.3.x86_64[SLES10-Updates] dependend
on hal
gnome-session-2.12.0-106.28.x86_64[SLES10-Updates] dependend on hal
gnome-screensaver-2.14.0-19.12.x86_64[SLES10-Updates] dependend on hal
evince-0.4.0-25.5.x86_64[SLES10-Updates] dependend on hal
xorg-x11-6.9.0-50.14.x86_64[System packages] dependend on permissions
xorg-x11-6.9.0-50.14.x86_64[System packages] is missing the
requirement permissions
util-linux-2.12r-35.6.x86_64[System packages] dependend on permissions
util-linux-2.12r-35.6.x86_64[System packages] is missing the
requirement permissions
rpm-4.4.2-43.7.x86_64[SLES10-Updates] dependend on permissions
openssh-4.2p1-18.12.x86_64[SLES10-Updates] dependend on permissions
gnuplot-4.0.0-20.2.x86_64[System packages] dependend on plotutils
gnuplot-4.0.0-20.2.x86_64[System packages] is missing the requirement
libplot.so.2()(64bit)
gnuplot-4.0.0-20.2.x86_64[System packages] provides gnuplot ==
4.0.0-20.2, but is scheduled to be uninstalled.
There are no installable providers of gnuplot for
sysstat-6.0.2-16.7.x86_64[SLES10-Updates]
util-linux-2.12r-35.6.x86_64[System packages] provides util-linux ==
2.12r-35.6, but is scheduled to be uninstalled.
There are no installable providers of util-linux for
mkinitrd-1.2-106.25.x86_64[SLES10-Updates]
xorg-x11-6.9.0-50.14.x86_64[System packages] provides xorg-x11 ==
6.9.0-50.14, but is scheduled to be uninstalled.
There are no installable providers of xorg-x11 for xorg-x11-
server-6.9.0-50.32.5.x86_64[SLES10-Updates]
gnome-vfs2-2.12.2-58.10.x86_64[System packages] provides
libgnomevfs-2.so.0()(64bit), but is scheduled to be uninstalled.
There are no installable providers of libgnomevfs-2.so.0()(64bit) for
gstreamer010-plugins-base-0.10.5-11.6.x86_64[SLES10-Updates]
libzypp-2.15.4-0.3.x86_64[System packages] provides libzypp.so.215()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libzypp.so.215()(64bit) for
yast2-perl-bindings-2.13.11-0.8.x86_64[System packages]
sax2-7.1-125.18.x86_64[System packages] provides sax2 == 7.1-125.18,
but is scheduled to be uninstalled.
There are no installable providers of sax2 for sax2-
libsax-7.1-125.18.x86_64[System packages]
hwinfo-12.34-0.2.x86_64[System packages] provides libhd.so.12()
(64bit), but is scheduled to be uninstalled.
There are no installable providers of libhd.so.12()(64bit) for yast2-
hardware-detection-2.13.3-13.2.x86_64[System packages]
sax2-libsax-perl-7.1-125.18.x86_64[System packages] is required by
other installed resolvable, so it won't be unlinked.
sax2-libsax-7.1-125.18.x86_64[System packages] is required by other
installed resolvable, so it won't be unlinked.
yast2-hardware-detection-2.13.3-13.2.x86_64[System packages] dependend
on hwinfo
yast2-hardware-detection-2.13.3-13.2.x86_64[System packages] is
missing the requirement hwinfo >= 11.10
sax2-libsax-7.1-125.18.x86_64[System packages] dependend on sax2
sax2-libsax-7.1-125.18.x86_64[System packages] is missing the
requirement sax2
yast2-perl-bindings-2.13.11-0.8.x86_64[System packages] dependend on
libzypp
yast2-perl-bindings-2.13.11-0.8.x86_64[System packages] is missing the
requirement libzypp.so.215()(64bit)
gstreamer010-plugins-base-0.10.5-11.6.x86_64[SLES10-Updates] dependend
on gnome-vfs2
xorg-x11-server-6.9.0-50.32.5.x86_64[SLES10-Updates] dependend on xorg-
x11
mkinitrd-1.2-106.25.x86_64[SLES10-Updates] dependend on util-linux
sysstat-6.0.2-16.7.x86_64[SLES10-Updates] dependend on gnuplot
yast2-qt-2.13.81-0.4.x86_64[System packages] provides yast2_ui, but is
scheduled to be uninstalled.
There are no installable providers of yast2_ui for
yast2-2.13.101-0.3.x86_64[System packages]
yast2-perl-bindings-2.13.11-0.8.x86_64[System packages] provides yast2-
perl-bindings == 2.13.11-0.8, but is scheduled to be uninstalled.
There are no installable providers of yast2-perl-bindings for yast2-
storage-2.13.70-0.5.x86_64[SLES10-Updates]
sax2-libsax-7.1-125.18.x86_64[System packages] provides sax2-libsax ==
7.1-125.18, but is scheduled to be uninstalled.
There are no installable providers of sax2-libsax for sax2-libsax-
perl-7.1-125.18.x86_64[System packages]
yast2-2.13.101-0.3.x86_64[System packages] dependend on yast2-hardware-
detection
yast2-2.13.101-0.3.x86_64[System packages] is missing the requirement
yast2-hardware-detection
sax2-libsax-perl-7.1-125.18.x86_64[System packages] dependend on sax2-
libsax
sax2-libsax-perl-7.1-125.18.x86_64[System packages] is missing the
requirement libsax.so.7()(64bit)
yast2-storage-2.13.70-0.5.x86_64[SLES10-Updates] dependend on yast2-
perl-bindings
yast2-installation-2.13.190-0.3.noarch[System packages] provides yast2-
installation == 2.13.190-0.3, but is scheduled to be uninstalled.
There are no installable providers of yast2-installation for yast2-
vm-2.13.62-4.2.x86_64[SLES10-Updates]
yast2-packager-2.13.171-0.4.x86_64[System packages] provides yast2-
packager == 2.13.171-0.4, but is scheduled to be uninstalled.
yast2-packager-2.13.139.1-0.2.x86_64[SLES10-Updates] provides yast2-
packager == 2.13.139.1-0.2, but it is uninstallable. Try installing
it on its own for more details.
There are no installable providers of yast2-packager for yast2-cd-
creator-2.13.5-6.2.noarch[SLES10-Updates]
sax2-libsax-perl-7.1-125.18.x86_64[System packages] provides sax2-
libsax-perl == 7.1-125.18, but is scheduled to be uninstalled.
There are no installable providers of sax2-libsax-perl for sax2-
ident-1.7-125.22.x86_64[SLES10-Updates]
yast2-2.13.101-0.3.x86_64[System packages] provides yast2 ==
2.13.101-0.3, but is scheduled to be uninstalled.
There are no installable providers of yast2 for yast2-samba-
client-2.13.24.2-0.2.noarch[SLES10-Updates]
yast2-2.13.101-0.3.x86_64[System packages] provides yast2 ==
2.13.101-0.3, but is scheduled to be uninstalled.
There are no installable providers of yast2 for yast2-
sound-2.13.11.1-0.2.x86_64[SLES10-Updates]
yast2-vm-2.13.62-4.2.x86_64[SLES10-Updates] dependend on yast2
yast2-sound-2.13.11.1-0.2.x86_64[SLES10-Updates] dependend on yast2
yast2-cd-creator-2.13.5-6.2.noarch[SLES10-Updates] dependend on yast2
yast2-samba-client-2.13.24.2-0.2.noarch[SLES10-Updates] dependend on
yast2
sax2-ident-1.7-125.22.x86_64[SLES10-Updates] dependend on sax2-libsax-
perl