It's been a long time since I've had problems with uploading a print
driver, but alas, I ran into one today.

Broker is NW6.5 SP6 with patch f on iPrint. 4.26 iPrint client.

Uploading latest driver (dated 9/13/07) to broker for
XP or Windows 2000 appears initially to copy files up, but the browser
just spins for a few minutes, then give the following error.

Bad Gateway!
The proxy server received an invalid response from an upstream server.

If you think this is a server error, please contact the webmaster.

Error 502
Wednesday, September 19, 2007 16:31:12

I seem to lose control of the RMS screen at that point. If I click
Manage Broker and reselect my broker object, and go to the RMS, the
driver is listed on the OS tab. I can add the driver to my printer
object, and it appears to download and work fine. Seems like something
in the upload isn't telling the client that it is "done" so it ends up
timing out, even though it worked.

Anyone else seeing similar problems? I've not seen it on any HP or
other drivers I've installed recently.