I'm having an issue on a number of Win XP SP2 machines with the Application
window (nalwin32) not coming up correctly.

Here's the pre-bits of info:
ZFD 7.01SP1
Applications associated to both Workstation and user object
Novell Client 4.91 SP4 for Windows
Users are not local admins.

Nalwin32 is launched via login script (have tried various command line
options. Normally we simply use : /min, but these have been removed for
testing.. have also used /TIME=30 to delay the launch of the NAL)

What will occur is that the splash screen will appear, but will terminate
after a second or two, and NALWIN will not remain in memory.

I have tried re-installing the agent (both with and without the remote
management enabled), deleting and re-importing the workstation, etc).
Assigning specific rights to the nalcache directory to the users group.
I've tried users in different contexts (so that they would only get
workstation associated apps), as well as importing the workstation into
different containers (only user apps).

The machines are on a variety of hardware (Dell GX270/280's, Gateway
4500/4610's). Some machines have dual displays (Intel onboard graphics),
but not all. I've also removed and re-installed both the video drivers, and
the AV software (symantec) as some older TIDS point to these being possible
problem components..

After running Naldiag, the workstation is connected, the NAL service is
running and the workstation helper is connected to the correct workstation

There are no obvious corrupted application objects.

Additionally, this behavior does NOT happen if I use the application
explorer (nalview/naldesk). It also does not occur if the local account is
an administrator as well.

I've tried enabling debug tracing, but I can't find much documentation on
what to look for in debugging the NAL startup.

Any ideas?