've been working on this problem for a couple of weeks now, googling
fixes, reading TIDs, etc. I'm now at my wit's end and hoping for some

iManager has worked fine for the last 2 years, then quit loading.
When trying to load from NRM, I get: Novell iManager does not respond
on <server/domain>.
Unable to find iManager in this eDirectory container.
Would you like to continue searching for iManager?

When trying to load from: https://<server/domain name>/nps/
I get a login screen. I enter an administrator's credentials, it
hangs forever, then returns: (Error -610) Illegal NDS Name. Avoid
using illegal characters or reduce the number of characters in the
object's name.
When I don't use the full context, I get this message:
(Error -634) The target server does not have a copy of what the source
server is requesting. Or, the source server has no objects that match
the request and has no referrals on which to search for the object.

Tomcat is running. Apache is running. LDAP appears to be running and
working like it's supposed to. C1 works fine. NRM works fine. Just
iManager will not load.

The LDAP-SSl, SSL CertificateIP, and SSL CertificateDNS certs were all
expired. They are all renewed now, and still no iManager.