I am new to Linux.

Is there a way for me to tell which CD and version (SLES or SLED / v9 or
v10) that was used to install the Linux box. I did uname and it tells me
kernel version 2.6.16.

The user needs kernel v2.6.20. Can someone give me instructions to update
the kernel.