Hello,

My first question is what version of Zen am I running? If I run zenver at
my NW 6.5 console I see Version=7.0.0.50819. If I run
sys:zenworkszfdversion I see what appear to be different version numbers
depending on the function (WakeOnLan, zenInvCommon, etc), some being 6.5
and some 7.0 (I actually think I saw a 4 for some).

I am testing a migration from ZEN (whatever version it turns out to be)
running on NW 6.5 to ZEN 7 on OES Linux. I've completed the installation
without issue.

I was able to use WOL on a workstation that had been previously imported.

I then unregistered the workstation, removed it from eDir, and then tried
to register it again, and I can't.

In /var/opt/novell/log/zenworks/awsi.log I see the message "Oct 10, 2007
10:57:09 AM javax.naming.CommunicationException: anonymous bind failed:
localhost:636 [Root exception is javax.net.ssl.SSLHandshakeException:
sun.security.validator.ValidatorException: No trusted certificate found]."

I also see "Oct 10, 2007 10:57:26 AM No import policy found."

In /var/opt/novell/log/zenworks/awsr.log I see the messages "Oct 10, 2007
10:38:20 AM javax.naming.CommunicationException: anonymous bind failed:
localhost:636 [Root exception is javax.net.ssl.SSLHandshakeException:
sun.security.validator.ValidatorException: No trusted certificate found]
Oct 10, 2007 10:38:20 AM No removal policy found" also.

I've read about associating the server with the policies, but I don't see
any place to make such an association. The only associations I see
pertain to the Server Package the policies are in, and pertain to rights
needed to create workstations.

I've read about adding the LDAP_SERVER and LDAP_TREENAME to
/etc/opt/novell/zenworks/zdm/novell-zdm-awsi.conf, which I've done
(although I can't get the LDAP_SERVER value correct, it seems--everything
I try results in a UnknownHostException in awsr.log--awsi.log doesn't make
any reference).

So, I'm at wits end, and would be grateful for any help.

Thank you.