Running a batch file from a network mapped drive to copy some files to a
local PC using Secure or Unsecure system users just refuses to work. Have
now wasted 2 hours trying to fix this but it just won't work. Just keep
getting the error Could not launch <application> (ID=3) The system cannot
find the path specified.

1) Doesn't matter whether I assign the application to users or workstation
objects or both.
2) The workstation object is imported, is registering correctly and has RF
rights to the directory in question. In have gone overboard and assigned
it explicit full rights.
3) Running as Normal runs fine except I need Admin rights to copy some
files to some user profile directoriys which fails with normal user.
4) In the Run Options, applications tab I have tried to use drive mappings
and UNC paths, as I did see a page which suggested you can't use drive
mappings here if using Secure or Unsecure system user. However UNC paths
fail too.
5) In the Run Options, Launch Scripts tab I have even tried mapping a
separate drive here and using that instead but that doesn't work.

How can I get this to work or is the task an impossible one because it's a
batch file I'm trying to run?