We just changed our 2 node NW 6.5 SP6 cluster from direct fiber
connections on our AX100 to fully redundant paths - 2 HBAs in each
server, 2 switches, 2 storage processors on the san (and yes, checked
and rechecked physical paths for full redundancy). We're using the
default hardware zoning on the silkworm 200E switches. We currently have
5 virtual disks.

All server access appears to work as normal, but the storage tech
suggested we modify our startup.ncf. Here's his suggestion:
--------------
#(Commented out by install...) LOAD POWPATH.CDM
#LOAD ACPIDRV.PSM
######## End PSM Drivers ########
LOAD IDECD.CDM
LOAD SCSIHD.CDM
LOAD PERC2.HAM SLOT=10019
LOAD ADPT160M.HAM SLOT=101
LOAD ADPT160M.HAM SLOT=102
######## End CDM Drivers ########
LOAD IDEATA.HAM SLOT=10009
#LOAD PEDGE3.HAM SLOT=1
LOAD POWPATH.CDM
LOAD QLCSFTE.CDM
LOAD QL2X00.HAM SLOT=2 /LUNS /ALLPATHS /PORTNAMES /QUALIFIED
LOAD QL2X00.HAM SLOT=3 /LUNS /ALLPATHS /PORTNAMES /QUALIFIED
######## End HAM Drivers ########
----------------

After checking out this most excellent forum and the qlogic
documentation, I wondered if I should tweak it to be like this:
----------------
SET MULTI-PATH SUPPORT = ON
#(Commented out by install...) LOAD POWPATH.CDM
#LOAD ACPIDRV.PSM
######## End PSM Drivers ########
LOAD IDECD.CDM
LOAD SCSIHD.CDM
LOAD QLCSFTE.CDM
######## End CDM Drivers ########
LOAD PERC2.HAM SLOT=10019
LOAD IDEATA.HAM SLOT=10009
#LOAD PEDGE3.HAM SLOT=1
LOAD ADPT160M.HAM SLOT=101
LOAD ADPT160M.HAM SLOT=102
LOAD POWPATH.CDM
LOAD QL2X00.HAM SLOT=2 /LUNS /ALLPATHS /PORTNAMES /QUALIFIED /MAXLUNS=15
LOAD QL2X00.HAM SLOT=3 /LUNS /ALLPATHS /PORTNAMES /QUALIFIED /MAXLUNS=15
######## End HAM Drivers ########
------------------

Change summary: set mp support at top, moved qlcsfte.cdm up to cdm
section, move adaptec drivers to HAM section, and set maxluns. Does this
look reasonable? Thanks.