Situation:

We have OESNetware server running DHCP/DNS services.

We have added the following paramenters:

3 Router 10.0.0.253
5 Name Server 10.0.0.2, 10.0.0.3
6 Domain Name Server 10.0.0.2, 10.0.0.3
60 Vendor Class Identifier PXEClient
66 TFTP Server Name 10.0.0.69
67 Boot File Name pxelinux.0
69 SMTP Server 10.0.0.2
70 POP3 Server 10.0.0.2
86 NDS Tree Name ST_MARKS_COLLEGE
87 NDS Context ST_MARKS


I have set up a TFTP server on an OESLinux system and it seems to work ok
(ie I can retrieve files from it with a workstation and tftp client)

PXE booting a workstation results in it getting an IP address fine.

Then we get:

PXE-E55 ProxyDHCP did not respond to request on port 4011.
PXE-M0F Exiting Intel Boot Agent.

I then tried setting up a TFTPD on a Win2K box and get the same result (and
yes, I changed the DHCP TFTP Server to the IP of the 2K box).

Same effect.

structure of the tftproot is

\tftproot
pxelinux.0
default
images\menu.txt
kernels\memdisk
images\smcipex.ima
(ima file produced from bootable floppy with client by winimage)

Tried putting everything in \tftproot and modifying default accordingly, no
change.

default contains:

prompt 1
default 1
timeout 300
display \display\menu.txt

# Image Computer
label 1
kernel \kernels\memdisk
append initrd=\images\smcipex.ima


EOF

menu contains:

Please select a boot option:

1. SMC Ipex (default)

Note: 'Default' will load automatically in 30 seconds.

EOF

I get the feeling it's not getting the right/full story from DHCP.
Are there problems with using Netware DHCP Server with PXE? If so what's
the fix?

Anyone had this problem? I really need to get PXE working.

TIA



--

Geoff Roberts
Computer Systems Manager
Saint Mark's College
Port Pirie, South Australia
geoffrobxATstmarksxdotppxdotcatholicxdoteduxdotaux
Remove the x's