We have three quirks showing consistently on all our (SLED10) machines
that I thought I would share with you. The bundles assigned are
- ZLM72IR1-Hot-Patch-bundle
- ZLM72-Hot-Patch-bundle
- SLED10-SP1-Updates-bundle
- SLED10-SP1-Online-bundle
- SLED10-Updates-bundle

The three issues are that
- /var/lib/zmd must be (re)moved after having upgraded to
ZLM72-Hot-Patch-bundle and ZLM72IR1-Hot-Patch-bundle (at least I
think it is after that point)
otherwise we get the same non-sense dependency failures [1]
- gnomemeeting and openh323 must be removed due to an unsatisfied
dependency on an old version of libpt_linux_x86_64_r.so (that belongs
to pwlib that is being upgraded to a newer version)
- gdm 2.8.0.7-57.29 is reported as being an invalid package[2]

I believe others on the list uses the procedure in #1 and that #2 is not
really an issue related to ZENworks, but rather just being bad packaging
of the rpm's; anyway, we don't use those two packages. I've got no idea
on #3, we've had it across two installations of the ZENworks server, so
I'm sure it isn't really a bad packages.

Any thoughts or comments?


Simon Holm Thgersen

[1] something like the following shows in the log
Updating libgnomeui-devel-2.12.0-28.4.x86_64[System packages] to
libgnomeui-devel-2.12.1-0.13.x86_64[Mandatory Bundles]
libgnomeui-2.12.0-28.4.x86_64[System packages] provides libgnomeui ==
2.12.0-28.4, but is scheduled to be uninstalled.
libgnomeui-2.12.0-28.4.x86_64[SLED-10-x86_64-Distro-Catalog] provides
libgnomeui == 2.12.0-28.4, but another version of that package is
already installed.
Can't satisfy requirement libgnomeui == 2.12.0 for
libgnomeui-devel-2.12.0-28.4.x86_64[System packages]
Can't install libgnomeui-devel-2.12.1-0.13.x86_64[Mandatory Bundles],
since libgnomeui-devel-2.12.1-0.13.x86_64[Mandatory Bundles] is
already marked as needing to be installed
Marking this resolution attempt as invalid.

and

03 Dec 2007 13:08:26 INFO Progress Progress.Stop Message:
Unresolved dependencies:
Updating spamassassin-3.1.3-2.2.x86_64[System packages] to
spamassassin-3.1.8-9.2.x86_64[Mandatory Bundles]
perl-spamassassin-3.1.3-2.2.x86_64[System packages] provides
perl-spamassassin == 3.1.3-2.2, but is scheduled to be uninstalled.
perl-spamassassin-3.1.3-2.2.x86_64[SLED-10-x86_64-Distro-Catalog]
provides perl-spamassassin == 3.1.3-2.2, but another version of that
package is already installed.
Can't satisfy requirement perl-spamassassin == 3.1.3 for
spamassassin-3.1.3-2.2.x86_64[System packages]
Can't install spamassassin-3.1.8-9.2.x86_64[Mandatory Bundles], since
spamassassin-3.1.8-9.2.x86_64[Mandatory Bundles] is already mark
ed as needing to be installed
Marking this resolution attempt as invalid.



[2] something like the following shows in the log
03 Dec 2007 23:09:57 ERROR ActionManager Failed to execute
scheduled action (install (bundles=cb4585adf47cc34d1a09b69e05692901)):
Bundle transaction failed: Invalid package: