Hello list.
We've got a problem with our vsftpd 2.0.4 on a SLES10 Sp1.
I want to chroot all users here, but it doesn't work. The user can walk
upwards in the directories.
I read several site to this problem. IMHO my config should work. But it
doesn't.

Here is my conf-file:

dirmessage_enable=YES
ftpd_banner="Willkommen"
ls_recurse_enable=NO
#hide_ids=YES
local_enable=YES
local_umask=022
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list

The list exists with permissions 600 to root

#local_max_rate=7200
anonymous_enable=NO
anon_world_readable_only=YES
#anon_upload_enable=NO
#anon_umask=022
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
#chown_uploads=YES
#chown_username=whoever
#anon_max_rate=7200
syslog_enable=YES
log_ftp_protocol=YES
xferlog_enable=YES
#vsftpd_log_file=/var/log/vsftpd.log
#xferlog_std_format=YES
#xferlog_file=/var/log/xferlog
#dual_log_enable=YES
#setproctitle_enable=YES
connect_from_port_20=YES
#idle_session_timeout=600
#data_connection_timeout=120
#async_abor_enable=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES
#pasv_enable=NO
pam_service_name=vsftpd
listen=YES
ssl_enable=NO

# Own settings:
# userlist_deny=NO
# userlist_enable=YES
# force_dot_files=NO
passwd_chroot_enable=YES
chmod_enable=NO

Any ideas?
Thanks in advance for your help.

Best regards.

Dirk Emmermacher