So I had this working fine in our test environment, but once we proceeded
with production I've run into problems. Every time I add a cluster
resource the resource fails to start and goes comatose with a Bad
Interpreter error. It appears to be mangling the script parsing and
reading ^M where it isn't.

This is on OES Linux SP2 (fully patched with rug pin --entire-channel
oes). I've tried creating the resource with ConsoleOne as well as
iManager 2.7 (both Firefox and IE).

The load script can be as simple as;
echo "Test Load".

The unload script can be as simple as;
echo "Test Unload."

The error in /var/log/messages is;
Dec 4 14:41:11 myserver ncs-resourced: test.load resource pid 25669
Dec 4 14:41:11 ,yserver ncs-resourced: test.load output: /bin/sh:
/var/opt/novell/ncs/test.load: /bin/bash^M: bad interpreter: No such file
or directory

If I edit the file with VI I see no lines with ^M after bash. If I run
the file with sh /etc/opt/novell/ncs/test.load it works fine. However if
I run the file iwth /etc/opt/novell/ncs/./test.load I receive the same

Any hints?