I have the most recent imaging CD, but it still does not work with quite a
few systems on our campus. I am aware that I can compile in drivers, but
have run into snags there - so for all intents and purposes, let's ignore
that option for now.

I have been trying to update the kernel on the imaging CD, and have had
good luck, for the most part. I was able to update the CD to kernel, and it boots fine, works with all our computers, and images 95%
of them without any problems.

However, some machines have an odd issue: The imaging process runs fine,
with no errors, and does lay down the data to the drive. When you reboot
the machine, you get either an "error loading operating system" error
message, or a black screen with a blinking white cursor.

Upon doing some further research, I've found an interesting common
denominator. On all the machines that have this happen, the zenworks
imaging software incorrectly reports the drive size. If I boot the CD and
run fdisk, it correctly sees a 40Gb drive, for example. Once in the img
program, however, it sees a 32Gb drive.

I've tried many different kernel versions, including one compiled with the
novell supplied, with the same result.

I'm wondering if anyone has any ideas as to why this would happen - and if
there is something beyond kernel updates that is required to make this
work. Any help would be *greatly* appreciated!