For those of you that will be running Linux apps that need to print from
the Linux command line but also want to use iPrint...

Command to use: lp

When you setup a printer in iManager iPrint/Create Printer, you are
asked for the LPR Printer Name. Fill this in with the name you wish to
use. (I use the same as the iPrint Printer Name entered in the first

This creates a printer you can print to from the command line.

Example: lp -d<LPR Printer Name>

However, you cannot do anything else. lpstat doesn't work, neither does
lpadmin. You can't get status, you can't set default printer, etc.

So... I install LPRng. Now's where the fun begins. First of
all--starting with OES2/SLES10, the Yast Software Manager complains like
*hell*. You have to click ignore about forty times just to get it to

You should also install lpdfilter since this includes the lprsetup
program, which allows you to create linux printers (not iPrint printers)
at the command line.

The flap! THough I've used this approach before, this is the first time
with OES2/SLES10. I could no longer print using lp, AND lpstat still
didn't work. Instead I would get the error could not rename
/tmp/whatever to lpq.0. Invalid cross-device link.

For those of you that don't know, one cannot hard link (vs symbolic
link) a file to another file on a separate partition. My /tmp dir and
/var dirs are on separate partitions--AS ALWAYS!

But this time, it was a problem. Anyway, after hours of playing around
with lpd.conf settings and lpr command line debug levels and logging I
finally discovered the following:

the following two directives added to the /etc/lpd.conf file:


tell lpd to create it's temp files on the /var partition, thus avoiding
the problem.

One last thing. The lpstat command always displays the last result
message. If you don't reprint something to the printer, the old message
will still be there and you will think you still have the problem. Be
sure and print something to the printer to get the latest results.


P.S. If anyone's interested in more on this, let me know. I have to go
back to work now :-)