I'm trying to figure how to set this correctly. The "request session"
is greyed out on workstations. I've checked the effective policy
packages for user and workstation and made sure that "allow user to
request remote session" is checked on but still the setting doesn't

Have I missing anything? I'm using ZfD7 SP1.