Is it a mandatory to assign the bundle of "Discover Applicable Updates
windows-x86-en-xpsp2" to the workstation group?

If yes, what is the best practice for it? (e.g. schedule ...)