I am not getting new inventory records even though I can see the Storage
Inventory service running, and the Storer apparently "Successfully stored
information for...".

Watching the Zenworks Inventory Service session screen in rConsoleJ I can
see the scanning and storage messages. I seem to be getting "Failure in
readStatusRecords" on certain workstations, not on others.

In Console1 I can browse to the Inventory Service object and view it's
properties. Under the Status Report, Server Status I get the following two
alerts:

Dictionary Consumer, Error, 2760: No update policy found.
Storer, Information, 108: The database is not initialized as it is being
upgraded.

I did a stopser *, then startser Inventory_service and it failed to load,
exit status -1. Here are the details from the zfs-startuplog:

>2007.12.13 10:04:02 [main] All modules have shutdown.

2007.12.13 10:04:03 [ZWS:Module] Creating a server socket on port 8089
2007.12.13 10:04:03 [ZWS:Module] Creating a server socket on port 65000
2007.12.13 10:04:03 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is done
initializing.
2007.12.13 10:04:03 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is
running...
Using data:ZENworkszfs-startup.log as the log file.
The ZENworks service loader is loading the modules specified in:
data:ZENworkszfs-startup.xml
Module started: com.novell.application.zenworks.services.console.C onsole
Module started:
com.novell.application.zenworks.services.webserver .ZenWebServer
2007.12.13 10:41:42 [Console:Module] Module
com.novell.application.zenworks.services.console.C onsole is done
initializing.
2007.12.13 10:41:42 [Console:Module] Module
com.novell.application.zenworks.services.console.C onsole is done.
2007.12.13 10:41:42 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is done
waiting.
2007.12.13 10:41:42 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is
initializing...
2007.12.13 10:41:43 [Console:Module] Module
com.novell.application.zenworks.services.console.C onsole is done
initializing.
2007.12.13 10:41:43 [Console:Module] Module
com.novell.application.zenworks.services.console.C onsole is done.
2007.12.13 10:41:43 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is done
waiting.
2007.12.13 10:41:43 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is
initializing...
2007.12.13 10:41:45 [ZWS:Module] Starting the ZENworks RPC Web Server (ZWS)
2007.12.13 10:41:45 [ZWS:Module] Loading the zws.properties file.
2007.12.13 10:41:45 [ZWS:Module] Loading servlets
2007.12.13 10:41:46 [ZWS:Module] Starting the ZENworks RPC Web Server (ZWS)
2007.12.13 10:41:46 [ZWS:Module] Loading the zws.properties file.
2007.12.13 10:41:46 [ZWS:Module] Loading servlet
com.novell.application.zenworks.services.servlets. XMLProxyServlet.class.....
2007.12.13 10:41:46 [ZWS:Module] Servlet loaded
2007.12.13 10:41:46 [ZWS:Module] Loading servlet
com.novell.application.zenworks.services.servlets. XMLRPCServlet.class.....
2007.12.13 10:41:46 [ZWS:Module] Servlet loaded
2007.12.13 10:41:46 [ZWS:Module] Socket timeout is set to 30000
2007.12.13 10:41:46 [ZWS:Module] Creating a server socket on port 8089
2007.12.13 10:41:46 [ZWS:Module] Creating a server socket on port 65000
2007.12.13 10:41:47 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is done
initializing.
2007.12.13 10:41:47 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer is
running...
2007.12.13 10:41:47 [ZWS:Module] Loading servlets
2007.12.13 10:41:49 [ZWS:Module] Loading servlet
com.novell.application.zenworks.services.servlets. XMLProxyServlet.class.....
2007.12.13 10:41:49 [ZWS:Module] Servlet loaded
2007.12.13 10:41:49 [ZWS:Module] Loading servlet
com.novell.application.zenworks.services.servlets. XMLRPCServlet.class.....
2007.12.13 10:41:49 [ZWS:Module] Servlet loaded
2007.12.13 10:41:49 [ZWS:Module] Socket timeout is set to 30000
2007.12.13 10:41:49 [ZWS:Module] Module
com.novell.application.zenworks.services.webserver .ZenWebServer failed to
initialize
2007.12.13 10:41:49 [ZWS:Module] *** Exception:
com.novell.application.zenworks.loader.Initializat ionException: The
ZENworks Service Loader is already running and cannot be loaded again.
This instance will now exit.
2007.12.13 10:41:50 [ZWS:Module]
com.novell.application.zenworks.loader.Initializat ionException: The
ZENworks Service Loader is already running and cannot be loaded again.
This instance will now exit.
at
com.novell.application.zenworks.services.webserver .ZenWebServer.initialize(ZenWebServer.java:499)
at
com.novell.application.zenworks.loader.ZENModuleTh read.run(ZENModuleThread.java:53)

2007.12.13 10:41:50 [main] All modules have shutdown.


Help?