I am trying to compile my first driver for Zenworks ( I have both Zen
7SP1IR1HP1 and ZCM10, imaging appears to be essentially the same ). I
finally set up a SLES10 server on that very hardware with the NIC I need a
driver for ( I got a source code r8168-8.004.00 from Realtek ). I registered
the server and got kernel updated - running default, not smp, 32 bit kernel When I PXE boot from Zen 7 server I have a kernel.

I followed the documentation, downloaded linux-,
created a symlink and ran 'module clean install' as per Realtek readme that
produced a r8168.ko file. I then tried running 'insmod r8168.ko' at the bash
prompt of my Zen PXE Linux ( just want to see if the module will load at
all ). I have tried several time double checking all steps but every time I
end up with that error -1 Invalid module format. I did not modify uname as I
thought there was need for me to.

I had to compile that very driver first to get my SLES10 machine connected
and it works fine. It even seems to work with the version I compiled with
Zen patch ( installed by accident on the server ) but not from Zenworks bash

Could you point me in the right direction as to what would be the next thing
to check or to try ? The driver that is included with 7SP1IR1HP1 ( r1000 )
generally works but imaging seems to be pretty slow with it, so I thought I
might as well learn how to compile those ..