Home

Results 1 to 7 of 7

Thread: Compiled driver - invalid module format

  1. #1
    Andrew T NNTP User

    Compiled driver - invalid module format

    Hi,

    I am trying to compile my first driver for Zenworks ( I have both Zen
    7SP1IR1HP1 and ZCM10, imaging appears to be essentially the same ). I
    finally set up a SLES10 server on that very hardware with the NIC I need a
    driver for ( I got a source code r8168-8.004.00 from Realtek ). I registered
    the server and got kernel updated - running default, not smp, 32 bit kernel
    2.6.16.27-0.9-default. When I PXE boot from Zen 7 server I have a
    2.6.16.46-0.12-default kernel.

    I followed the documentation, downloaded linux-2.6.16.46-0.12-pulsar.tgz,
    created a symlink and ran 'module clean install' as per Realtek readme that
    produced a r8168.ko file. I then tried running 'insmod r8168.ko' at the bash
    prompt of my Zen PXE Linux ( just want to see if the module will load at
    all ). I have tried several time double checking all steps but every time I
    end up with that error -1 Invalid module format. I did not modify uname as I
    thought there was need for me to.

    I had to compile that very driver first to get my SLES10 machine connected
    and it works fine. It even seems to work with the version I compiled with
    Zen patch ( installed by accident on the server ) but not from Zenworks bash
    prompt.

    Could you point me in the right direction as to what would be the next thing
    to check or to try ? The driver that is included with 7SP1IR1HP1 ( r1000 )
    generally works but imaging seems to be pretty slow with it, so I thought I
    might as well learn how to compile those ..

    Andrew




  2. #2
    Kurt Finlayson NNTP User

    Re: Compiled driver - invalid module format

    Andrew T wrote:
    > Hi,
    >
    > I am trying to compile my first driver for Zenworks ( I have both Zen
    > 7SP1IR1HP1 and ZCM10, imaging appears to be essentially the same ). I
    > finally set up a SLES10 server on that very hardware with the NIC I need a
    > driver for ( I got a source code r8168-8.004.00 from Realtek ). I registered
    > the server and got kernel updated - running default, not smp, 32 bit kernel
    > 2.6.16.27-0.9-default. When I PXE boot from Zen 7 server I have a
    > 2.6.16.46-0.12-default kernel.
    >
    > I followed the documentation, downloaded linux-2.6.16.46-0.12-pulsar.tgz,
    > created a symlink and ran 'module clean install' as per Realtek readme that
    > produced a r8168.ko file. I then tried running 'insmod r8168.ko' at the bash
    > prompt of my Zen PXE Linux ( just want to see if the module will load at
    > all ). I have tried several time double checking all steps but every time I
    > end up with that error -1 Invalid module format. I did not modify uname as I
    > thought there was need for me to.
    >
    > I had to compile that very driver first to get my SLES10 machine connected
    > and it works fine. It even seems to work with the version I compiled with
    > Zen patch ( installed by accident on the server ) but not from Zenworks bash
    > prompt.
    >
    > Could you point me in the right direction as to what would be the next thing
    > to check or to try ? The driver that is included with 7SP1IR1HP1 ( r1000 )
    > generally works but imaging seems to be pretty slow with it, so I thought I
    > might as well learn how to compile those ..
    >
    > Andrew
    >
    >
    >


    Have you tried compiling on a SLES 10 SP1 server?

    ---Kurt

  3. #3
    Andrew T NNTP User

    Re: Compiled driver - invalid module format

    > Have you tried compiling on a SLES 10 SP1 server?

    No, I installed that SLES10 from a Novell promo ( trial ) DVD without SP1.
    Why, does it matter ? I will try to apply SP1 via online update then .. as
    all other SLES we have are 64 bit so I had to find one that was not. Is it
    possible to compile a driver for Zen on a 64 bit Linux ? Cross compiling
    is it ?

    Andrew


  4. #4
    Andrew T NNTP User

    Re: Compiled driver - worked Ok

    I have updated SLES10 with the latest patches / SP and recompiled the driver
    which then loaded Ok from bash prompt in PXE, woo hoo. Thanks for the hint
    although I should have read p.809 65.5 Adding or Updating LAN Drivers
    properly where it does say "Zenworks 7 is based on SLES10 SP1, kernel
    version 2.6.16.46-0.12".

    Andrew

    "Andrew T" <a@b.com> wrote in message
    news:cMX9j.10954$k06.24@kovat.provo.novell.com...
    >> Have you tried compiling on a SLES 10 SP1 server?

    >
    > No, I installed that SLES10 from a Novell promo ( trial ) DVD without SP1.
    > Why, does it matter ? I will try to apply SP1 via online update then .. as
    > all other SLES we have are 64 bit so I had to find one that was not. Is it
    > possible to compile a driver for Zen on a 64 bit Linux ? Cross compiling
    > is it ?
    >
    > Andrew
    >




  5. #5
    Kurt Finlayson NNTP User

    Re: Compiled driver - invalid module format

    Andrew T wrote:
    >> Have you tried compiling on a SLES 10 SP1 server?

    >
    > No, I installed that SLES10 from a Novell promo ( trial ) DVD without
    > SP1. Why, does it matter ? I will try to apply SP1 via online update
    > then .. as all other SLES we have are 64 bit so I had to find one that
    > was not. Is it possible to compile a driver for Zen on a 64 bit Linux ?
    > Cross compiling is it ?
    >
    > Andrew
    >


    Nope, you have to compile on the default kernel. There might be a way
    but I do not know of a way.

    ---Kurt

  6. #6
    Join Date
    Apr 2008
    Posts
    2

    Re: Compiled driver - invalid module format

    Andrew, I am having the same issue with this. Would it be possible to contact me? my email is jdowns@sripley.k12.in.us

  7. #7
    Join Date
    Apr 2008
    Location
    central florida
    Posts
    20

    Re: Compiled driver - invalid module format

    i spent i think 3 days figuring this out. make sure you have "module versioning support" disabled in the kernel config before compiling. also make sure any SMP features are turned off as well (symmetric multi-processing support).

    here's some pics:
    http://resinblade.net/images/linux/kern1.png
    http://resinblade.net/images/linux/kern2.png

    eric

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •