We have come across an interesting difference between novell provided nss volumes and linux provided nss volumes and wonder if there is a solution 'out there'.

We have a NAL application which creates a couple of directories in the users %HOME DIRECTORY%, one of which is a templates directory into which we place various user oriented document templates, thus enabling them to 'roam' without loosing their 'normal.dot' file. (Oh yes we are still using office 97).

This works fine when the users home directory is based on a Novell supplied NSS volume. However, when the users directory is based on a Linux supplied NSS volume we get:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~
Could not get needed resources for application [ApplicationName] to be launched (id=1)

Problem: Invalid drive path [\\servername\volume\users]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~

Tried using the create directory under 'distribution options, application files'.
Tried using a script under 'distribution options, distribution scripts' which uses a mkdir command.
Tried using a script under 'run options, launch scripts' to do the same thing.

All seem to result in the same error.

The users have all rights but S to their home directory.

Is there a way round this?
Is it a known problem?

Suggestions welcome ....